It is currently November 26th, 2014, 3:47 pm Advanced search

Resolved: Netflix not working

General questions, FAQs about XIOS DS Media Play

Resolved: Netflix not working

Postby Moods » July 12th, 2013, 4:56 am

Hey guys, I just got my Pivos XD and so far so good, however I ran into an issue with Netflix, I can start it, I can browse the library, but as soon as I start a movie or series, it plays for about 2 secs, then shows me a black screen with some weird pixelated boxes.

If theres subs within the first 2 seconds I can see those, I have tried the newest netflix from the Play store, and an older version I got from the net, but no luck.
Moods
 
Posts: 1
Joined: July 12th, 2013, 4:53 am

Re: Netflix not working

Postby aasoror » July 12th, 2013, 2:40 pm

Which firmware do you have loaded ?
The AIOS wiki - The AIOS Semiofficial firmwares
Calling upon ALL AIOSers, your feedback is needed -- Calling upon ALL XIOSers, your feedback is needed
XIOS XBMC: Setup -- Keep the annoying XIOS developers happy, always attach a log with your bug report, here is how.
User avatar
aasoror
Pivos Employee
 
Posts: 12514
Joined: September 26th, 2011, 5:18 pm

Re: Netflix not working

Postby zedan » July 14th, 2013, 2:29 pm

I had this same issues on the latest ICS firmware, it was ultimately the reason I went back to Linux.

Loading the app and selecting a show/movie worked smoothly, but as soon as I tried to watch anything, it would freeze while buffering a few seconds into the show/movie.
Pivos Xios DS -> XBMC-Linux-M1 Beta 051013
Raspberry Pi -> RaspBMC-Gotham-Alpha
Ouya -> XBMC Gotham Alpha8
zedan
 
Posts: 14
Joined: August 28th, 2012, 5:12 am
Location: Brampton, Ontario Canada

Re: Netflix not working

Postby xbmc4u » July 16th, 2013, 9:16 am

Moods » July 12th, 2013, 6:56 am wrote:Hey guys, I just got my Pivos XD and so far so good, however I ran into an issue with Netflix, I can start it, I can browse the library, but as soon as I start a movie or series, it plays for about 2 secs, then shows me a black screen with some weird pixelated boxes.

If theres subs within the first 2 seconds I can see those, I have tried the newest netflix from the Play store, and an older version I got from the net, but no luck.


It seems that you have to be blessed by god to get Netlfix to work on the Pivos XIOS DS. It's never worked correctly for me regardless of M1 or M3 version (so I had to go back to my Apple TV for that) but it has worked well for others.

Regards.
xbmc4u
TOFUer
 
Posts: 641
Joined: July 17th, 2012, 12:01 pm

Re: Netflix not working

Postby dorfd1 » July 16th, 2013, 5:16 pm

xbmc4u wrote:
It seems that you have to be blessed by god to get Netlfix to work on the Pivos XIOS DS. It's never worked correctly for me regardless of M1 or M3 version (so I had to go back to my Apple TV for that) but it has worked well for others.

Regards.


Netflix has never worked correctly for me either.

Sent from my YP-G1 using Tapatalk 2
dorfd1
Hardcore
 
Posts: 145
Joined: December 27th, 2012, 5:37 pm

Re: Netflix not working

Postby carveitup » July 16th, 2013, 7:12 pm

Does run for me if I use a wired connection but it is really slow to load the menu and the video and I get occasional audio blips. Works way better on my old, cheap android phone.
carveitup
Dedicated
 
Posts: 56
Joined: February 18th, 2013, 8:14 pm

Re: Netflix not working

Postby dorfd1 » July 17th, 2013, 2:02 pm

I think if we can get a 3.0 kernel running on our device, a lot of issues will be fixed, netflix should work correctly and we will have a performance boost.

I believe android 4.0 and higher require a 3.0 kernel in order to have hw acceleration working correctly.

Sent from my YP-G1 using Tapatalk 2
dorfd1
Hardcore
 
Posts: 145
Joined: December 27th, 2012, 5:37 pm

Re: Netflix not working

Postby carveitup » July 17th, 2013, 5:06 pm

I've wondered if some significant performance improvement could be seen by simply optimizing the cache size for writing to the mSD. There are several Android apps out there that change this value and produce considerably faster read and write speeds which should help buffering. Unfortunately, these apps don't work on the Pivos due to different configuration of the devices file structure than most systems. Most of these apps work by increasing the value in the following file:

/sys/devices/virtual/bdi/179:0/read_ahead_kb

Default value is typically 128kb, but many people suggest that 4096kb is much more effective. I tried an app called SD Speed Increase on my phone and saw a substantial improvement in both read and write speed.

On the Xios, the directory for mSD is different.
carveitup
Dedicated
 
Posts: 56
Joined: February 18th, 2013, 8:14 pm

Re: Netflix not working

Postby zepperdude » July 22nd, 2013, 2:33 pm

Any tips on getting this working? I recently switch from running XBMC Linux to Android so I could use Netflix and I am experiencing the same problems as everyone else I guess - works for a short time (sometimes 2 seconds sometimes longer) and then just freezes. Running 05/10/13 build and latest download of Netflix from Play Store.
zepperdude
 
Posts: 11
Joined: January 14th, 2013, 10:29 am

Re: Netflix not working

Postby aasoror » July 22nd, 2013, 6:38 pm

zepperdude » July 22nd, 2013, 5:33 pm wrote:Any tips on getting this working? I recently switch from running XBMC Linux to Android so I could use Netflix and I am experiencing the same problems as everyone else I guess - works for a short time (sometimes 2 seconds sometimes longer) and then just freezes. Running 05/10/13 build and latest download of Netflix from Play Store.

There is something messed up with last few netflix APK updates.
I just tested the most recent version and does exhibit the 2 second buffering, tried the one before it and I get buffering every 13 minutes or so.
I will look into it.
The AIOS wiki - The AIOS Semiofficial firmwares
Calling upon ALL AIOSers, your feedback is needed -- Calling upon ALL XIOSers, your feedback is needed
XIOS XBMC: Setup -- Keep the annoying XIOS developers happy, always attach a log with your bug report, here is how.
User avatar
aasoror
Pivos Employee
 
Posts: 12514
Joined: September 26th, 2011, 5:18 pm

Next

Return to General Questions

Who is online

Users browsing this forum: Bing [Bot] and 2 guests